Horizon Hosting - Degraded performance on the billing panel – Incident details

All systems operational

Degraded performance on the billing panel

Resolved
Degraded performance
Started over 2 years agoLasted less than a minute

Affected

Panels

Operational from 1:55 PM to 1:55 PM

Billing Panel

Operational from 1:55 PM to 1:55 PM

Updates
  • Investigating
    Investigating

    We have noticed degraded performance on our billing panel, and this issue is linked to the German VPS problems. The billing panel should still be accessible, but slower than normal. We apologise for any inconvenience this may cause

  • Resolved
    Resolved

    We have noticed degraded performance on our billing panel, and this issue is linked to the German VPS problems. The billing panel should still be accessible, but slower than normal. We apologise for any inconvenience this may cause