Horizon Hosting - Unexpected Network Outage – Incident details

All systems operational

Unexpected Network Outage

Resolved
Major outage
Started about 1 year agoLasted about 2 hours

Affected

Updates
  • Resolved
    Resolved

    We have now resolved this incident. This was caused by a router failure - we are continuting to speak with out network provider to find out what caused this and how they can prevent this in future.

    We again apologise for any inconvenience caused.

  • Investigating
    Investigating

    We are aware of an issue affecting one of our nodes in the UK causing network problems for the game panel and some client VPS services. We are working with out network provider to resolve this and apologise for any inconvenience.