Horizon Hosting - US-VPS-02 Outage – Incident details
Report an issue
Get updates
Email
Discord
Google Chat
Webhook
API
Report an issue
Get updates
All systems operational
US-VPS-02 Outage
Resolved
Operational
Started 6 months ago
Lasted about 7 hours
Updates
Resolved
April 20, 2025 at 6:08 PM
Resolved
April 20, 2025 at 6:08 PM
This incident has been resolved, a weather event had caused an outage at the datacenter.
Investigating
April 20, 2025 at 11:35 AM
Investigating
April 20, 2025 at 11:35 AM
We are currently investigating this incident.