Horizon Hosting - US-VPS-02 – Incident details
Report an issue
Get updates
Email
Discord
Google Chat
Webhook
API
Report an issue
Get updates
All systems operational
US-VPS-02
Resolved
Operational
Started 7 months ago
Lasted about 3 hours
Updates
Resolved
May 04, 2025 at 12:56 AM
Resolved
May 04, 2025 at 12:56 AM
This incident has been resolved.
Investigating
May 03, 2025 at 10:10 PM
Investigating
May 03, 2025 at 10:10 PM
We are currently communicating with the datacentre to investigate this incident.