Horizon Hosting - US-GAME-02 Outage – Incident details

All systems operational

US-GAME-02 Outage

Resolved
Major outage
Started about 1 year agoLasted about 12 hours
Updates
  • Resolved
    Resolved

    We have noticed that the network has been stable now for a while. The provider had found a second break in the fibre cable, so the issue took longer to resolve.

    Apologies again for the inconvenience.

  • Update
    Update

    The provider are continuing to work on a fix for this incident. They are currently repairing the final part of the fibre cable, and they expect to have services restored by 14:30 GMT.

  • Identified
    Identified

    We have spoken to our provider and the issue has been identified as a broken fibre cable in New Jersey, for one of the upstream networks. They are working on a repair and hope to have it completed within an hour from the time of writing.

  • Investigating
    Investigating

    We are currently investigating this incident. Apologies for the inconvenience.