Horizon Hosting - US-GAME-12 Outage – Incident details

All systems operational

US-GAME-12 Outage

Resolved
Major outage
Started 7 months agoLasted about 11 hours

Affected

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating
    We are currently investigating this incident.