Horizon Hosting - US-GAME-09 Outage – Incident details
Report an issue
Get updates
Email
Discord
Google Chat
Webhook
API
Report an issue
Get updates
All systems operational
US-GAME-09 Outage
Resolved
Operational
Started 11 months ago
Lasted 36 minutes
Updates
Resolved
February 27, 2024 at 8:53 AM
Resolved
February 27, 2024 at 8:53 AM
This incident has been resolved.
Investigating
February 27, 2024 at 8:17 AM
Investigating
February 27, 2024 at 8:17 AM
We are currently investigating this incident.