Scheduled for October 20, 2025 at 4:00 PM – 5:00 PM
Affects
Game Nodes
Under maintenance from 4:00 PM to 5:00 PM
US-GAME-14
Under maintenance from 4:00 PM to 5:00 PM
Updates
Completed
October 20, 2025 at 5:00 PM
Completed
October 20, 2025 at 5:00 PM
Maintenance has completed successfully
In progress
October 20, 2025 at 4:00 PM
In progress
October 20, 2025 at 4:00 PM
Maintenance is now in progress
Planned
October 20, 2025 at 4:00 PM
Planned
October 20, 2025 at 4:00 PM
We have been informed by our provider for this location that the hardware requires the PDU to be replaced. This will temporarily effect all services on this node. For minimal disruption we ask that you turn off your services ahead of time to avoid abrupt disconnections.