Horizon Hosting - Gamepanel and US-GAME-01 issues – Incident details
Report an issue
Get updates
Email
Discord
Google Chat
Webhook
API
Report an issue
Get updates
All systems operational
Gamepanel and US-GAME-01 issues
Resolved
Partial outage
Started over 2 years ago
Lasted 10 minutes
Updates
Resolved
August 16, 2022 at 8:09 PM
Resolved
August 16, 2022 at 8:09 PM
The systems have now recovered
Investigating
August 16, 2022 at 8:00 PM
Investigating
August 16, 2022 at 8:00 PM
We are currently investigating this incident.