Horizon Hosting - Web Hosting Outage – Incident details
Report an issue
Get updates
Email
Discord
Google Chat
Webhook
API
Report an issue
Get updates
All systems operational
Web Hosting Outage
Resolved
Partial outage
Started about 2 years ago
Lasted 35 minutes
Updates
Resolved
December 19, 2022 at 5:27 PM
Resolved
December 19, 2022 at 5:27 PM
The issue is now resolved. Thank you for your patience
Investigating
December 19, 2022 at 4:52 PM
Investigating
December 19, 2022 at 4:52 PM
We are currently investigating this incident.