Horizon Hosting - US-GAME-15 Outage – Incident details

All systems operational

US-GAME-15 Outage

Resolved
Partial outage
Started 4 months agoLasted about 1 hour

Affected

Game Nodes

Partial outage from 5:41 PM to 6:58 PM

US-GAME-15

Partial outage from 5:41 PM to 6:58 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We have identified an issue with upstream providers and are working to resolve the issue.

  • Investigating
    Investigating

    We are currently investigating this incident.