Horizon Hosting - Unexpected Outage – Incident details

All systems operational

Unexpected Outage

Resolved
Operational
Started 2 months agoLasted 16 minutes

Affected

Panels

Major outage from 11:03 AM to 11:19 AM

Billing Panel

Major outage from 11:03 AM to 11:19 AM

Game Panel

Major outage from 11:03 AM to 11:19 AM

VPS Panel

Major outage from 11:03 AM to 11:19 AM

Updates
  • Resolved
    Resolved

    An issue was identified with upstream providers, this incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating the cause of this incident.