Horizon Hosting - German VPS services inaccessible – Incident details

All systems operational

German VPS services inaccessible

Resolved
Partial outage
Started over 2 years agoLasted less than a minute

Affected

Updates
  • Resolved
    Resolved

    This issue has now been resolved and German VPS services are now accessible again.

  • Investigating
    Investigating

    We are currently investigating this incident - we apologise for any issues this has caused