Horizon Hosting - DE-01 Down – Incident details

All systems operational

DE-01 Down

Resolved
Major outage
Started over 2 years agoLasted 10 minutes

Affected

Updates
  • Resolved
    Resolved

    The issue was identified by a DDoS attack which has now been stopped by the filter. We apologise for the inconvenience.

  • Monitoring
    Monitoring

    DE-01 has recovered - we are now monitoring the system

  • Investigating
    Investigating

    We are currently investigating this incident.