Horizon Hosting - Unexpected UK-WEB-01 Outage – Incident details

All systems operational

Unexpected UK-WEB-01 Outage

Resolved
Major outage
Started about 2 years agoLasted 15 minutes

Affected

Panels

Major outage from 11:40 AM to 11:55 AM

cPanel

Major outage from 11:40 AM to 11:55 AM

Billing Panel

Major outage from 11:40 AM to 11:55 AM

Updates
  • Resolved
    Resolved

    The issue has now been resolved, but a cause has not yet been identified.

  • Investigating
    Investigating

    We are currently investigating this incident.