Horizon Hosting - US-GAME-02 Outage – Incident details

All systems operational

US-GAME-02 Outage

Resolved
Major outage
Started 11 months agoLasted 15 minutes

Affected

Updates
  • Resolved
    Resolved

    This incident has been resolved. We are working with our network provider to establish a cause for this incident.

    Apologies again for the inconvenience.

  • Investigating
    Investigating

    We are currently investigating this incident. Apologies for the inconvenience.